DRM plugin for Calibre 5.x

(Plugin to Calibre)

Here is the latest release (Dec 2020) of the DeDrm plugin for the Calibre 5.x version, meaning with this version, you can convert your kindle books to pdf using the new Calibre. You will not require the older version Calibre 4.23. Simply download the new Calibre and use with this DeDrm. All download links are provided as belwo.

Please note THIS VERSION SHOULD BE USED with the CALIBRE 5.x. If you are using the older calibre 4.x you should be using the older DRM i.e. 6.8.1.






SUBSCRIBE

SUBSCRIBE

Welcome to Hey, Let's Learn Something!

Please sign up here to receive the latest updates on our blogs, tutorials and download section :)

Thank you for subscribing :)